The Trimble SketchUp e-commerce storefront is down for unplanned maintenance.
Incident Report for SketchUp
Resolved
This incident has been resolved.
Posted Sep 04, 2021 - 17:27 MDT
Investigating
We are currently investigating this issue.
Posted Sep 04, 2021 - 12:24 MDT
This incident affected: SketchUp E-commerce.