Trimble Entitlements is down for unplanned maintenance
Incident Report for SketchUp
Resolved
This incident has been resolved.
Posted Sep 27, 2021 - 08:33 MDT
Investigating
The entitlements system is experiencing performance degradation and will affect access to SketchUp products.
Posted Sep 27, 2021 - 08:23 MDT
This incident affected: 3D Warehouse Login, SketchUp Client Login, SketchUp Entitlements, SketchUp E-commerce, SketchUp Trimble Connect, SketchUp Profile Service, SketchUp Add Location Service, and SketchUp Licensing Service.