Login
Incident Report for SketchUp
Resolved
This incident has been resolved.
Posted Oct 07, 2022 - 09:15 MDT
Update
Service degradation with login has been resolved.
Posted Oct 07, 2022 - 09:14 MDT
Update
We are continuing the investigation of this issue and will update when performance is back to normal.
Posted Oct 06, 2022 - 17:11 MDT
Update
We are continuing to investigate this issue.
Posted Oct 06, 2022 - 15:45 MDT
Update
We are continuing to investigate this issue.
Posted Oct 06, 2022 - 14:28 MDT
Update
We are continuing to investigate this issue.
Posted Oct 06, 2022 - 13:30 MDT
Update
We are continuing to investigate this issue.
Posted Oct 06, 2022 - 11:09 MDT
Update
We are continuing to investigate this issue.
Posted Oct 06, 2022 - 09:45 MDT
Investigating
We are experiencing service degradation with login. If you have issues logging in, please reach out to SketchUp support.
Posted Oct 06, 2022 - 08:21 MDT
This incident affected: 3D Warehouse Login and SketchUp Client Login.