3D Warehouse Outage
Incident Report for 3D Warehouse
Resolved
This incident has been resolved.
Posted Sep 09, 2017 - 00:40 MDT
Monitoring
We believe that the issues affecting 3D Warehouse are now solved, but will continue to monitor the situation.
Posted Sep 08, 2017 - 22:31 MDT
Investigating
3D Warehouse is experiencing an outage right now. We are currently investigating the cause. We apologize for any inconvenience this causes.
Posted Sep 08, 2017 - 21:08 MDT