Sefaira web application unavalable to Educational users
Incident
2025-11-10T13:33:00.0000000Z
Sefaira web application unavalable to Educational users
Status: closed
Start:
2025-11-10T12:45:00.0000000Z
End:
2025-11-10T13:33:00.0000000Z
Duration: 48 minutes
Affected Components:
SketchUp Sefaira
SketchUp Login
Maps
Sefaira Web
Sefaira Revit Plugin
Sefaira SketchUp Plugin
Update
2025-11-10T12:45:00.0000000Z
2025-11-10T12:45:00.0000000Z
Educational users are currently unable to log in to the Sefaira web application.
We are working on a fix and this should be resolved shortly.
Resolved
2025-11-10T13:33:00.0000000Z
2025-11-10T13:33:00.0000000Z
Normal service is now restored