Service interruption on SketchUp for Mobile
Incident
2025-08-22T13:13:00.0000000Z
Service interruption on SketchUp for Mobile
Status: closed
Start:
2025-08-21T13:21:00.0000000Z
End:
2025-08-22T13:13:00.0000000Z
Duration: 23 hours 52 minutes
Affected Components:
SketchUp for Mobile
SketchUp Login
Trimble Connect
SketchUp Entitlements
Live Components
Add Location
Update
2025-08-21T13:21:00.0000000Z
2025-08-21T13:21:00.0000000Z
We have been seeing reports of a new error prompting users to accept the terms and privacy policy repeatedly. The issue is under investigation.
Resolved
2025-08-22T13:13:00.0000000Z
2025-08-22T13:13:00.0000000Z
A new update is being made available to prevent this issue.